iPhone 5 devices need urgent updates or many features will stop working.
iPhone 5 devices need urgent updates or many features will stop working.

Update older iPhones now or never

Apple is rushing to get the word out to users of older iPhone devices that they need to urgently update or else lose several key functionalities for a bizarre event that only happens once every two decades.

iPhone users still clinging to their seven-year-old iPhone 5 or eight-year-old iPhone 4S models need to update to the latest software this week, or risk losing access to GPS, email, iCloud, the App Store and other web services.

Apple CEO Tim Cook introducing the iPhone 5 in 2012, the first iPhone to be unveiled after the death of Steve Jobs.
Apple CEO Tim Cook introducing the iPhone 5 in 2012, the first iPhone to be unveiled after the death of Steve Jobs.

The flaw is caused by a strange tech phenomenon called GPS Rollover, which happens approximately once every 20 years.

The issue is caused by the way GPS technology keeps track of time.

RELATED: Upgrade if you have this iPhone

The system counts weeks using binary digits, which means it can only count up to a maximum of 1024 weeks.

This means every 1024 weeks, or around 19.7 years, the counter rolls over, which can cause problems for programs and devices that rely on GPS for the correct date and time but haven't been coded correctly to account for the rollover.

They could be fooled into displaying a date from 20 or 40 years ago, or just stop working all together.

The rollover began happening for some systems in April this year, when widely used GPS components from US conglomerate Honeywell rolled over, leading to the temporary grounding of Bureau of Meteorology weather balloons and some Boeing aeroplanes.

A technological limit in the way global position systems count weeks means the devices need updating or could lose functionality and display the wrong time and date.
A technological limit in the way global position systems count weeks means the devices need updating or could lose functionality and display the wrong time and date.

Affected Apple devices will rollover shortly before midnight on Sunday, November 3 and need to be updated before then to avoid a time-consuming back up and restoration process using a separate computer.

RELATED: Google claims "quantum supremacy"

iPhone 5 users should update to iOS 10.3.4, while iPhone 4S users need to be on iOS 9.3.6.

If you have your phone set to automatically update you probably won't have to do anything, but it's worth checking what version of the operating software your device is using just to be safe.

You can check your software version number in the device settings by tapping on the General field and then tapping About.

The GPS rollover issue is also set to disable cellular iPad models up to the 4th generation iPad.

A re you still hanging on to one of the older Apple models? Let us know in the comments below.